Over a million developers have joined DZone.
{{announcement.body}}
{{announcement.title}}

Windows Phone Emulator: Hyper-V isn’t on

DZone's Guide to

Windows Phone Emulator: Hyper-V isn’t on

· Mobile Zone
Free Resource

Launching an app doesn’t need to be daunting. Whether you’re just getting started or need a refresher on mobile app testing best practices, this guide is your resource! Brought to you in partnership with Perfecto

I attribute this entire blog post to Scott Kerfoot who provided these instructions to me Smile

If you should stumble upon this dialog box …

clip_image001

…  you should then click the "Turn on Hyper-V" link.  The Windows Features dialog box will then appear as seen here:

clip_image001[6]

Notice that Hyper-V is not selected. To enable it, select the box next to it, and click OK. You will now be required to reboot.  After rebooting, attempt to run the emulator again. Hopefully this was successful for you.  However, you may encounter the following dialog box:

clip_image001[8]

If you get this error, select the "Join the Hyper-V Administrators security group" option and click Retry.  You will now need to log off and log back on again for security permissions to take effect.  Try running the emulator again.  Hopefully you have success and are ready to develop!  One way or another, please leave a comment here if this information was helpful, or if you have additional information to provide.



Keep up with the latest DevTest Jargon with the latest Mobile DevTest Dictionary. Brought to you in partnership with Perfecto.

Topics:

Published at DZone with permission of Michael Palermo, DZone MVB. See the original article here.

Opinions expressed by DZone contributors are their own.

THE DZONE NEWSLETTER

Dev Resources & Solutions Straight to Your Inbox

Thanks for subscribing!

Awesome! Check your inbox to verify your email so you can start receiving the latest in tech news and resources.

X

{{ parent.title || parent.header.title}}

{{ parent.tldr }}

{{ parent.urlSource.name }}